Menu
Simba Technologies
Simba Technologies

SimbaEngine X SDK 10.1.3
Developing Drivers for Data Stores Without SQL

Supported Platforms

This section lists the platforms and compilers that are supported by the SimbaEngine X SDK version 10.1.3.

Hardware Requirements

On all supported platforms, the minimum hardware requirements are as follows:

  • 8 GB of free disk space
  • 1 GB RAM

Software Requirements

The following table lists the supported platforms and compilers:

Platform

Versions

Compilers

Bits

Windows

7, 8, 8.1, 10

Server 2008, 2008 R2

Server 2012, 2012 R2

Server 2016

Visual Studio 2013 & 2015

32, 64

Linux

CentOS/RHEL 5, 6, 7

SLES 11, 12

Ubuntu 12.04, 14.04

Debian 7, 8

GNU GCC 4.4.7

32, 64

macOS

10.9, 10.10, 10.11

Xcode 5.1, 6.1, 7.2

32, 64

Solaris Sparc

10, 11

Oracle Solaris Studio 12.4 (C++ Compiler 5.13) or,

GNU GCC 4.9.2

32, 64

Solaris AMD64

10, 11

Oracle Solaris Studio 12.4 (C++ Compiler 5.13) or,

GNU GCC 4.9.2

32, 64

AIX PowerPC

6.1, 7.1

XL C/C++ V13.1

32, 64

HP-UX Itanium

11.31

HP C/aC++ A.06.28.1

32, 64

JDBC and JDK Support

The following list shows the JDK requirements for each version of JDBC:

  • JDBC 4.0 used with JDK 1.6
  • JDBC 4.1 used with JDK 1.7
  • JDBC 4.2 used with JDK 1.8

Note:

Compiling your custom JDBC driver as Hybrid creates a driver that supports both JDK 1.6 and JDK 1.7, where the correct version is detected at runtime.