Menu
Simba Technologies
Simba Technologies

Simba Spark JDBC Driver with SQL Connector 2.6.16
Installation and Configuration Guide

System Requirements

Each machine where you use the Simba Spark JDBC Driver must have Java Runtime Environment (JRE) 7.0 or 8.0 or 11.0 installed. If you are using the driver with JDBC API version 4.2, then you must use JRE 8.0.

The driver supports Apache Spark versions 1.6 and 2.1 through 2.4.

Important:

  • Support for Spark 1.6, 2.1, and 2.2 is deprecated, and will be removed in a future release of this driver. For more information, see the release notes.
  • The driver only supports connections to Spark Thrift Server instances. It does not support connections to Shark Server instances.